XRAY - Model racing cars

It is currently Thu Jul 19, 2018 17:49:06

All times are UTC + 2 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: XB4 problems
PostPosted: Sun Aug 20, 2017 21:30:55 
Offline

Joined: Sun Aug 20, 2017 21:26:14
Posts: 1
New dealer here and i have sold a few of the 4wd kits.

2 have had incorrect front wheels in them. They came with 14mm hex wheels instead of 12mm hex wheels. Customer did not notice this untill tires were glued onto the wheels and mounted on the car.

One was built friday and raced on saturday. After 2 battery packs, the front ring and pinion gear failed. Possibly not heat treated?

Anyone else experience these problems? Thanks.


Top
 Profile  
 
 Post subject: Re: XB4 problems
PostPosted: Mon Aug 21, 2017 00:47:03 
Offline

Joined: Tue May 15, 2007 04:36:09
Posts: 5
Location: TN
hey bigfoot it was the rear that had the 14mm hex and I will try to post some pic of the front ring and pinion . car had 10000 in front and rear and slipper was half turn so it would not ride the bearing and assembly was correct . I was on highbite clay running dirtwebs using ty setup and a 10.5 motor. pretty big letdown for first run out with buggy .


Top
 Profile  
 
 Post subject: Re: XB4 problems
PostPosted: Thu Aug 24, 2017 19:37:44 
Offline

Joined: Tue May 15, 2007 04:36:09
Posts: 5
Location: TN
xray America sent warranty diff and sent me 14mm hubs , got it in two days and took 2nd place on wed . thanks X-ray and big foot for the amazing turn time


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 2 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group